What can we fix in Illustrator? Vote for or report a bug.

High Sierra (macOS 10.13) GPU rendering issues with RGB document - Intel Graphics

Illustrator 21.1.0 has issues with GPU rendering in the latest High Sierra public betas:

Paths will appear jagged and generally do not display correctly.

Altering the zoom level affects these artefacts.

Switching off GPU rendering altogether fixes the issue but this way, performance is obviously affected.

Additional Note: Works correctly in CMYK document.

380 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Kris Janssen shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

278 comments

Comments are closed
  • Chad M commented  ·   ·  Flag as inappropriate

    HI @Salwaak! Yes... 10.13.(3) still has those issues. The 10.13.(4) beta seems to have fixed my rendering issues.

  • Salwaak commented  ·   ·  Flag as inappropriate

    Hello Chad, I have the same 13" Macbook Pro and same intel plus 650 but the latest version of the ios is 10.13.3!! Still the same Issue :(

  • Chad M commented  ·   ·  Flag as inappropriate

    Just installed MacOS 10.13.4 on my 13" Macbook Pro with the Intel Iris Plus 650 and it seems this update has resolved this issue for me in Illustrator and InDesign!!

    So far so good in RGB mode. Can anyone else install the beta and confirm this fix?

  • Martin commented  ·   ·  Flag as inappropriate

    MacBook Pro 2017 - 10.13.3 - same problem. Shame on you APPLE and Shame on you ADOBE.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Still having this issues, running on MacBook Pro 2017 - intel 640 plus, please fix it :(

  • Andrea Il Mio commented  ·   ·  Flag as inappropriate

    I just updated to 10.13.3 it does not work again ...
    The Apple support says that it has never recognized the problem and that the solution must come from Adobe.

  • Anonymous commented  ·   ·  Flag as inappropriate

    This has apparently been around since 2015... I am only noticing it now after installing High Sierra. At this point, nobody should be surprised at Adobe's amount of bugs. Adobe cares more about making the next incompatible version of software instead of just perfecting what we are all using right now. They just create more bugs.

    https://forums.adobe.com/thread/1872322

  • Anonymous commented  ·   ·  Flag as inappropriate

    Preview keeps defaulting to GPU in both Illustrator AND Indesign, and glitches with what looks to be tears/odd shapes in the on screen renderings. I need to manually switch the preview to CPU very often to see my work normally. Very annoying. Mac/High Sierra. Core i7 3.33ghz, tons of RAM, Macbook Pro.

  • Abel Peeters commented  ·   ·  Flag as inappropriate

    Today I got updates for Photoshop, XD, Premiere and After Effects. Why aren't you guys working on this bug?

  • Anonymous commented  ·   ·  Flag as inappropriate

    We need this to be fixed ASAP. My company is paying for annual subscription and we have several projects running now. This issue is slowing down all our projects, I have reported this issue to Adobe many times with no response.

  • Jett commented  ·   ·  Flag as inappropriate

    Called adobe today. And Apple. Apple said it's on Adobe's end and Adobe said it was on Apple's end????

  • Chad M commented  ·   ·  Flag as inappropriate

    I have been wrestling with this issue since I bought my new 13" Macbook Pro. It's extremely frustrating that neither Adobe, nor Apple it seems, is trying to fix this. This drowns a professional workflow and grinds things to a halt. We need a fix ASAP Adobe. This is B.S.

  • Bea commented  ·   ·  Flag as inappropriate

    I pay yearly to CC, somebody please fix this mess.
    I have tons of project waiting in line to be finished. This issue slows me down as ****.

  • Anonymous commented  ·   ·  Flag as inappropriate

    —>Anonymous

    Yeah, no way ,sherlock.

    Everyone knows that, but illustrator gets hella slow then 😑

  • Anonymous commented  ·   ·  Flag as inappropriate

    In Illustrator

    Go to Preferences > GPU Performance
    Untick box -GPU Performance.

    This fixed the bug for me.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I lost two whole days at work just because of this bug. Am I getting a discount or an apology ?
    No!
    What happens if I dont pay to adobe each month? do I get a couple of extra days to pay up?
    No!
    unbelievable.

Feedback and Knowledge Base