What can we fix in Illustrator? Vote for or report a bug.

High Sierra (macOS 10.13) GPU rendering issues with RGB document - Intel Graphics

Illustrator 21.1.0 has issues with GPU rendering in the latest High Sierra public betas:

Paths will appear jagged and generally do not display correctly.

Altering the zoom level affects these artefacts.

Switching off GPU rendering altogether fixes the issue but this way, performance is obviously affected.

Additional Note: Works correctly in CMYK document.

380 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Kris Janssen shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

278 comments

Comments are closed
  • Anonymous commented  ·   ·  Flag as inappropriate

    @Ron Finch Probably unrelated to the graphics issues we are talking about here.

  • Roni Finch commented  ·   ·  Flag as inappropriate

    Radeon Pro 555 2 GB graphics - Although my issue is close. I cant select, the hand tool keeps things and zooms all around, hitting keyboard shortcut keys isnt recognized. I have to hit escape but it just happens again. I turned of GPU and changed the color mode. what next? I need to revise a file today! Recently upgraded to High Sierra and all CC apps are up to date. The lag is crazy. Basically not working.

  • Brandee commented  ·   ·  Flag as inappropriate

    Im not sure how to explain this so I attached the pictures. it only happens with the pen tool and it's really stressing me out. please fix it.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Intel HD Graphics 530 1536mb also experiences this issue on macOS 10.13.2. The disable GPU Preview workaround was successful.

  • Hal commented  ·   ·  Flag as inappropriate

    I broke down and traded for a 15” MBP with dedicated graphics.

  • Michael commented  ·   ·  Flag as inappropriate

    Its not only Apple. With the Dell xps 13 there are the same Problems....

    Noe I bought a MBP with TB 2016 ans still the same Problems -.-

  • Michelle commented  ·   ·  Flag as inappropriate

    I am having the same exact issue. How do we fix this? I am on Mac OS 10.13.3, MacBook Pro 13 inch Late 2016, four thunderbolt 3 ports, 2.9 Ghz with 8gb

  • Anonymous commented  ·   ·  Flag as inappropriate

    @Anonymous: Because we work with companies and clients that work with Illustrator and other Adobe apps. I like Affinity for personal projects, but at university and at work, I do rely on Illustrator.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Same problem here and really annoyed! How can it be such an issue is known for 6 months and still not fixed? I pay a lot of money for this software and expect it to run smoothly.

    Right now I can't really use PS, ID, and Ilu

  • Wayne commented  ·   ·  Flag as inappropriate

    When will they fix this issue? I can't really work with my Illustrator, Indesign, and Photoshop properly because of all those glitch. I didn't paid for those software for glitching all day long, please fix this asap.

  • Colin commented  ·   ·  Flag as inappropriate

    I would advise against those that rely on their computers for work to NOT install a beta version of an operating system.

  • Juan Houter commented  ·   ·  Flag as inappropriate

    Is the 10.13.4 beta safe to install then? How is the overall stability of the system?
    Else this is not a viable option.

  • Stefan commented  ·   ·  Flag as inappropriate

    The issue "seems" to be resolved, BUT now a new issue has surfaced from the suggested resolution to beta.

    Screenshot:
    https://www.dropbox.com/s/2g9mn4m08x5gcji/Adobe%20Error%20Prompt.png?dl=0

    *** Note for Everyone: ***
    If you have a 13" MacBook Pro like I once did your are asking for trouble regarding anything graphically, given those models only support 1.5GB of VRAM when the "minimum Requirements" for Adobe Software is 2GB" and that is the "minimum" not the Recommended. So go get yourself a 15" MacBook Pro or Higher and save yourself the headache like I went though.

  • Anonymous commented  ·   ·  Flag as inappropriate

    fails for me with Intel HD Graphics 615. Converting to cmyk or disabling gpu works around the issue

Feedback and Knowledge Base