What can we fix in Illustrator? Vote for or report a bug.


My kerning worked just fine about an hour ago, but now every time I try to add a custom kerning value it gives me the warning: Kerning on extended selections can only be set to Auto or 0.

I can't seem to get this to go away.
I uninstalled & reinstalled Illustrator and it is still happening.
I tried many fonts of different types, and it still won't work.


36 votes
Sign in
Sign in with: Facebook Google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

We have the fix available in the latest release. Please update Illustrator using Adobe Creative Cloud application to the latest build for version Illustrator CC 22.1.
Please refer to our knowledge base FAQhttps://illustrator.uservoice.com/knowledgebase/articles/1844590 if you face difficulty in update.
Or get in touch with us at any of the other support channels – https://helpx.adobe.com/support.html

Warm Regards,
Ashutosh Chaturvedi | Sr. Quality Engineering Manager – Illustrator
Adobe. Make It an Experience.


Sign in
Sign in with: Facebook Google
Signed in as (Sign out)
  • Alana commented  ·   ·  Flag as inappropriate

    I have just run into this issue in the middle of working on a file. It went from working for the first 25 minutes on the file to getting this error. I just did the update and the issue is still there.

  • More Spinach commented  ·   ·  Flag as inappropriate

    Not available at all. Illustrator latest as of Feb 14, 2019 still doing this idiotic thing. Why is Illustrator being made clunkier and clunkier??

  • Andrew D. commented  ·   ·  Flag as inappropriate

    All the issues with Type have NOT been fixed whatsoever. I've currently uninstalled the latest version of Illustrator TWICE. Once, without deleting all data and then again with deleting all data.

  • Mark S commented  ·   ·  Flag as inappropriate

    Still happening, I even uninstalled Ai and reinstalled but still can't kern properly.

  • Sarah commented  ·   ·  Flag as inappropriate

    Mine is doing this too. I press ESC to dismiss the dialog box but if I try to adjust kerning again, Illustrator crashes. I've lost work on the same file twice because I forget that KERNING DOESN'T WORK. Just for the record, I do have automatic data recovery turned on but I can't set it up to save constantly—it slows everything down.

  • Kate commented  ·   ·  Flag as inappropriate

    STILL. BROKEN. Come on Adobe. This software is too expensive to have so many **** long-term problems.

  • Lindsey commented  ·   ·  Flag as inappropriate

    I'm having this problem too. Why do i bother updating my software??

  • Andrew Waring commented  ·   ·  Flag as inappropriate

    Still an issue. The save shortcut still works thankfully but the interruptions to work-flow and productivity are something I thought Adobe would take seriously.

  • Anonymous commented  ·   ·  Flag as inappropriate

    The link posted by the admin no longer is available and the 22.0.2 version does not seem to be available in my updates. PLEASE ADDRESS!!!!!

  • Pfeirfly commented  ·   ·  Flag as inappropriate

    "Kerning on extended selections" just cropped up for me today when I updated 2017. Installed the pre-release build and this did not fix the issue. This is incredibly frustrating!

  • J Rizzo commented  ·   ·  Flag as inappropriate

    "kerning on extended selections" is still an issue and ruining my typography. What the heck!!?

  • Teemu commented  ·   ·  Flag as inappropriate

    Godamn.. how can this kind of f*ckups exist on software that should have been tested and tried?

    ..anyways, for time being, ALT + O seems to be solution to get rid of the warning message, so you don't need to force quit Illustrator. I haven't found any other way to close the warning..

  • Norman commented  ·   ·  Flag as inappropriate

    Ai 22.0.1 (macOS High Sierra v10.13.2)

    When inputing a value for kerning in character palette, sometimes a dialog box pops up that reads "Kerning on extended selections can only be set to auto or zero..." From that point, I cannot click ok, Ai is innoperable and I have to force quit.

  • Ryan commented  ·   ·  Flag as inappropriate

    When the popup appears, it won't allow you to click OK, but you can press enter on your keyboard and it will go away. Super annoying that I can't switch the kerning to Optical. It seems to work for some text sections, but not others. All the same typeface.

← Previous 1 3

Feedback and Knowledge Base