What can we fix in Illustrator? Vote for or report a bug.

Rotation Handle Tolerance overrides scale and selection functionality while using Wacom.

Hiya. I have an issue with the Selection tool and the rotation handle functionality overriding both scale and shift+selection of other objects while using a Wacom.

Essentially, the rotation functionality tolerance seems to be 2-3 times higher than when using a mouse, which means that I have to zoom in far in order to either scale or select a nearby object.

This behaviour has been in every version of Illustrator since the original Illustrator CC - which behaved flawlessly.

I've also had it occur on 2 different computers with 2 different Wacom devices (Intuous 5 and Cintiq 13HD) and multiple versions of the Mac operating system (Yosemite through to Sierra).

You can see a video of the behaviour attached below.

1. Version of Illustrator: CC2018 (but same occurs in 2017, 2015, 2014)
2. Steps taken: Using the selection tool I attempt to shift+select a nearby object or scale the selected object.
3. Expected Result: Shift-selecting the nearby object or scaling the selected object.
4. Actual Result: The current object goes into rotate mode.

Thanks!
Chris

133 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Chris Phillips shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →

76 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    Similar issue here. Even if there is no other object nearby, it's difficult to select and transform as expected.

    It works with expanded shapes, but not with regular shapes.

    Trying to demonstrate in this Video:
    https://vimeo.com/263234996?ref=em-share

    Working on OS Sierra with latest Illustrator CC and intuos Pro (tried many different drivers)

  • Anonymous commented  ·   ·  Flag as inappropriate

    Hello.

    Same issue here :
    longterm issue with using the wacom-tablet, intuos pro , with Illustrator CC, I cannot select objects that are close together:

    Please see this video I made for reference :
    https://www.youtube.com/watch?v=f0qT5qgukK4

    - While the object on the left is selected, i try to click on the shape to the right
    expected behaviour: the object on the right is selected.
    behaviour : the object on the right is rotating,
    One cs6 this works as expected (even on smaller zoomlevels , eg. 50%)

    This is a longstanding issue an it really degrades productivity since the introduction of the illustrator CC suite.
    I am a wacom/illustrator user for +10 years now, but i am really dissapointed in how this software-hardware combo has become worser of the years.

  • MsC commented  ·   ·  Flag as inappropriate

    Didn't mean to repost the previous commenter.
    Just saying I am having the same issues on Macbook pro 2011 and I noticed it in the last few versions of Illustrator cc Hate the time suck

  • Anonymous commented  ·   ·  Flag as inappropriate

    It's March 2018, this is still a problem. Still not fixed. Please fix as there are thousands of others who probably aren't taking the time to comment.
    This issue is with v22.1 so much so that it has significantly reduced my productivity and my boss is screaming that I can't get files out with a thousand layers out like I use to.
    Zooming in and out constantly is a horrid drain on my productivity and deadlines that can't be excused away to my clients!!!!!
    using a macbook pro 2017, High Sierra, Illustrator cc v22.1. Logitech trackball and Intous touch tablet with pen.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I too have had this problem for the last few versions of Illustrator - so annoying. Really spoils the enjoyment of using Illustrator. I'm constantly having to zoom right into objects to resize them. I have gone back to using CC5 at home, as it works so much faster and smoother.

    At work I'm using a Wacom Bamboo CTH0460 tablet with OS Sierra 10.12.6 with the latest version of Illustrator 22.1 and get this problem occuring. I don't appear to have the problem when using a mouse so must be a Wacom thing.

  • Dirkjan commented  ·   ·  Flag as inappropriate

    Same problems here. It is really, really frustrating... It all worked pitch perfect for years, and suddenly...?

    I'm also working on a Wacom Cintiq screen, so maybe the same root-issue here.
    Really hoping for a fix!

  • Andrea commented  ·   ·  Flag as inappropriate

    I noticed this has to do something with the new shape widget, which you can't really disable in general.
    Workaround: If you have one of those simple shapes behaving awkward:
    Got to: Object > Shape > Expand Shape.
    Gets you back to the "normal" behavior, for this particular shape.

    Still needs to be fixed though. Wacom somehow is getting confused by these kind of shapes.

  • Andrea commented  ·   ·  Flag as inappropriate

    Same issues here. Just startet with CC a month ago and can't believe what's going on on my display. How can anyone work with this....For now I decided to go back to Illustrator CS6 in order to get my work done efficiently without going crazy.
    Working on Sierra 10.12.6, Intuos Pro and also Intuos 4, driver 6.3.27-2. I tried different older wacom drivers, and older Mac OS - same thing. CS6 running perfectly, CC (2017, 2018) not.

    Mouse working properly, so it makes me believe it's a wacom problem.
    Haven't been using a mouse for years, so that's not an option.

    Interesting though CS6 is not affected, regardless which tablet or driver.

    A solution for this issue would make me very happy.

  • Anonymous commented  ·   ·  Flag as inappropriate

    I've noticed that if you have more then then 4 anchors on a square then your able to resize without any problems no matter how small the object is. And my mouse works fine, so its undoubtedly a wacom issue.

    Wacom Support gave me some help, unfortunately that didn't work out. Maybe you'll have better luck Chris? Se answer below. I've mailed them again. If you've solved this issue please let me know, thanks!

    "In this case an outdated or corrupt preference file could be causing an issue, please follow the instructions shown below:

    Go to the Wacom Folder and open Wacom Utility (you can also find it typing "Wacom" on the operating system search).
    Under "All User Preferences", please select "Remove".
    Disconnect the tablet from the computer and remove the driver using the Wacom Utility. After removing the driver with the utility, you can manually check to see if anything is left behind in the following folders. So while in our desktop we want to click on ‘Go’ (upper left corner), then on ‘Computer’. Once inside, please access your main hard drive (by default should be named Macintosh HD). Once we’re here anything that’s related to Wacom, would need to be removed from the folders. The same will have to be checked in any respective User’s folder on the system. On OS X 10.7 Lion or later, the User Library folder has been hidden. To access it, you must select 'Go' from the top of Finder and select 'Go to folder...’. Here, enter ' ~/Library ' to access the current user's Library folder. Please check for Wacom related files and remove them from inside the next folders:
    Applications/Wacom Tablet

    Library/Application Support/Tablet

    Library/Frameworks/WacomMultiTouch.framework

    Library/Internet Plugins/WacomTabletPlugin.plugin

    Library/Launch Agents/com.wacom.wacomtablet.plist

    Library/LaunchDaemons/com.wacom.displayhelper.plist

    Library/LaunchDaemons/com.wacom.RemoveTabletHelpter.plist

    Library/LaunchDaemons/com.wacom.TabletHelper.plist

    Library/PreferencePanes/WacomTablet.prefpane

    Library/Preferences/Tablet

    Library/PriveledgedHelperTools/com.wacom.RemoveTabletHelper

    Library/PriveledgedHelperTools/com.wacom.TabletHelper

    Users//Library/Preferences/com.wacom.ProfessionalTablet.plist

    Users//Library/Preferences/com.wacom.wacomtablet.prefs

    Users//Library/Preferences/com.wacom.wacomtouch.prefs

    After this is complete then there should not be any leftover files of a previous Wacom driver file. A restart and a repair of your disk permissions would be important steps before installing a driver. Again, make sure that the tablet is plugged directly into the computer, not into a USB hub or keyboard/monitor.

    Next, please proceed with the driver installation:

    A restart will be required after installing the driver, please make sure to close and save all your work before following these instructions.

    Disconnect the tablet from the computer.
    Download and install the driver from:
    http://tablet.wacom.co.jp/download/driver/WacomTablet_6.3.25-2.dmg
    As always, make sure your tablet is connected directly to your computer. Avoid using USB hubs, keyboard/monitor ports, or docking stations with the tablets, as they can cause inconsistent behavior."

  • Neal Maher commented  ·   ·  Flag as inappropriate

    Oh man, yes, please fix this! So much hair torn out over this frustrating issue.

  • Afonso Gonsalves commented  ·   ·  Flag as inappropriate

    Please please please fix this. It has to be the single most annoying issue with Illustrator, and makes an otherwise awesome tool absolutely nerve-wrecking.

1 2 4 Next →

Feedback and Knowledge Base